It took me forever to figure out what was going wrong with my script. We were asked to build a simple weather app, in which we input our current location and the app will quickly give us the latest weather forecast. We had to install a gem called Barometer, which is a recommended gem by the instructors. I went ahead and installed Barometer and read its README and other documentation on how to use the gem in our scripts.

From there, I used some simple Ruby functions to make it work. Once I thought that I got things working, something went wrong. I thought it was my faulty code or that there was some kind of an error on the installed Barometer gem. After bugging the tutors and classmates on the class Google Groups, I finally figured out why. Apparently, I don’t have the bundler dependency management installed because I’m currently using a somewhat outdated version of Ruby, 1 I had to install the tzinfo-data (Time Zone Data Info) gem manually, and that’s what fixed the problem.

My code is here on GitHub. Because we are now required to push all of our assignment files to GitHub, I’m not going to paste this on the Gist.

I am 2 days behind Skillcrush 204: Sinatra and ActiveRecord class because I got so busy offline: cleaning up my room and helping out with my brother’s wedding stuff. In a way, I have done a lot of art, but I haven’t had the time to really blog about them here. If you follow my Instagram, you can check out some shots of my practice art and DIY stuff, so yes, I have been quite busy.

Awrighty, time to go to bed. I still got a lot of catching up to do. 😅

On the sidenote…

  1. I did install another gem called uru that would easily let me switch Ruby versions. I am now using 2.3, the latest because an assignment in the intro to Sinatra and RSpec class required Ruby v. 2.2 and that I was currently using 2.1.